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Overview 

CM-900 is an embedded board based on STMicroelectronics’ STM32F103C8 

Cortex-M3 MCU(Datasheet). The board has 32 pins (16 data pins, 10 analog input 

pins), 5 dedicated ports for Dynamixel (2 TTL, 2 RS-485, 1 for LX-series); a micro-

USB type B port for programming and communications; DC power jack and 2-pin 

battery connector, reset switch; and a JTAG header. 

The CM-900 hardware and software are open-source; support in Windows, Mac 

OSX, and Linux for convenient and easy development of robots 

 

Note: the CM-900 is not compatible with RoboPlus, use ROBOTIS CM-9 for 

development. 
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I   Sales presentation 

1 Getting started with the CM-900 

Let’s have a look at the CM-900. With your working PC follow these step by 
step instructions. 

1.1 Windows 

1.1.1 Have the CM-900 and USB Cable ready. 

The cable is a type B micro-USB; the same type as with most smartphones. 

 

1.1.2 Download ROBOTIS CM9 development environment 

Download the most recent version of ROBOTIS CM9. You can get the most 

recent version by clicking on the link below. 

http://www.robotsource.org/xe/Circle_CM9_Developer_World 

 

Look for “Notice” entries. 

 

The Windows-version release is shown on the image below; click to download 

the compressed file.  
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Download the compressed file on your computer. Decompress the file and run 

ROBOTIS CM-9; the USB folder (\drivers) will also appear. 

1.1.3 Connect the CM-900 to the PC. 

Connect the CM-900 to the PC with the USB cable. 

      
<connect the CM-900 to the PC> 

Please refrain from connecting the CM-900 to the PC via USB hub. We 
recommend connecting the CM-900 to the PC directly. The USB hub may 
not be able to provide enough electrical current to the CM-900 to 
properly download programs. Connect the CM-900 to an USB port with 
guaranteed enough electrical current supply. 
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1.1.4 Install device drivers. 

The CM-900 will appear as “ROBOTIS Virtual COM Port” when connected to 

the PC in Windows Device Manager. 

 

Click with the right mouse button -> choose “Update Driver Software” 
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Select “Browse my computer for driver softeware”. 

             Choose “Manually search for drivers.” 

             

Click on “search” and go to (ROBOTIS\drivers) directory. 
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During driver installation you may encounter the following message; simply 

click on “install drivers anyways.” 

 

Upon successful installation you will see “successfully updated software 

driver.” 

 

From the device manager always remember the port number from ROBOTIS 

Virtual COM Port. If connecting the device to another USB port then the 

number may change 
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1.1.5  Run ROBOTIS CM-9. 

From the decompressed file directory (\ROBOTIS) double-click on ROBOTIS 

CM-9.exe. 

 

1.1.6  Open the Blink example. 

FIle -> Examples -> Digital -> Blink 
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 1.1.7  Select a board. 

       Tools ->Board-> ROBOTIS CM-900 Rev 1.0 

        
 

 1.1.8   Select serial port. 

 This is the same number from the Virtual COM device in Windows Device 

Manager. 

 

1.1.9 Download the code 

 

1.1.10 Troubleshooting Windows 8 USB driver installation 

Under Advanced options in PC settings select “do not enforce driver signature” 

then install the CM-900 USB drivers. 

Move the mouse pointer to the upper right side of the screen. When the menu 

pops click on Settings 
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Click on Change PC settings located at the bottom right. 

 

Click on General and Select advanced startup (click on Restart now button).
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Select troubleshoot 

 

Select advanced options. 

 

Select startup setup. 
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Click on Restart located at the bottom right. 

 

Click on the 7th option “disable driver signature enforcement.” 

 

Click on Install this driver software anyway. After restarting the PC connect the 

CM-900 and install drivers. 
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1.2 Linux 

1.2.1 Have the CM-900 and USB Cable ready 

The cable is a type B micro-USB; the same type as with most smartphones

 

1.2.2 Download the ROBOTIS CM-9 Linux release 

Download the 32-bit package for 32-bit versions of your Linux OS; 64-bit 

package for 64-bit version of Linux. 

http://www.robotsource.org/xe/Circle_CM9_Developer_World 
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After downloading input the following command 

 

~$tar –xvzf ROBOTIS_v0.9.8_linux32.tar.gz 

 

Or use the right mouse click to decompress the tarball package 
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The decompressed file will show a ROBOTIS directory. 

 
 

1.2.3 Check for JRE installation.  

To check input the command java –version. 

            

If not installed simply get JRE via the apt-get command. 

Run openjdk-7-jre-headless. 

                   $sudo apt-get install openjdk-7-jre 

                    

Press the Y key. 

Once installation is complete enter the command java –version 
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Upon successful installation of JRE run ROBOTIS CM-9. 

1.2.4 Connect the CM-900 to the PC. 

Connect the CM-900 to the PC with the USB cable. 

  
                <connect the CM-900 to the PC> 

Please refrain from connecting the CM-900 to the PC via USB hub. We 
recommend connecting the CM-900 to the PC directly. The USB hub may 
not be able to provide enough electrical current to the CM-900 to 
properly download programs. Connect the CM-900 to an USB port with 
guaranteed enough electrical current supply. 

1.2.5 Run ROBOTIS CM-9. 

From a terminal window go to ROBOTIS directory and enter the command./ 

ROBOTIS CM-9. 

 

Or double-click on the executable, and click on Run 
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1.2.6 Open Blink example 
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1.2.7 Select a board. 

If the CM-900 hardware version is Rev 1.0 or higher then select ROBOTIS 

CM-900 Rev 1.0. 

 

1.2.8 Select serial port. 

Select ttyACMX device. 

             

1.2.9 Download the code 
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1.3 Mac OS X 

1.3.1 Have the CM-900 and USB cable ready. 

The cable is a type B micro-USB; the same type as with most smartphones 

            

1.3.2 Download ROBOTIS CM9 Mac OS X release 

Download the most recent version of ROBOTIS CM9. You can get the most 

recent version by clicking on the link below. 

http://www.robotsource.org/xe/Circle_CM9_Developer_World 

Look for “Notice” entries. 
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Once download is complete double-click on the dmg and mount it. 

 

Drag ROBOTIS icon to the Applications folder 

 

Wait until transfer is complete 

 

Once transfer is complete go to the Applications folder and double-click 

ROBOTIS.app. 
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1.3.3 Connect the CM-900 to the Mac 

Connect the CM-900 to the Mac with the USB cable. 

 
Please refrain from connecting the CM-900 to the PC via USB hub. We 
recommend connecting the CM-900 to the PC directly. The USB hub may 
not be able to provide enough electrical current to the CM-900 to properly 
download programs. Connect the CM-900 to an USB port with guaranteed 
enough electrical current supply. 

1.3.4 Run ROBOTIS CM9 

From the Applications folder double-click on ROBOTIS.app. 

 
 

Simply click on open 
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1.3.5 Open the Blink example 
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1.3.6 Select the board 

 

1.3.7 Select serial port 

 

1.3.8 Download the code 
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2 CM-900 hardware 

2.1 Illustration of the CM-900 

 

2.2  Parts label 

 

2.2.1 Micro USB (type B): provides the CM-900 with downloading and 

communication capabilities via PC, in addition to electrical power from USB’s 

5V. Use the included USB cable or any other conventional USB cable you 

may likely have lying around. 

2.2.2 Reset switch : resets the CM-900 CPU 

2.2.3 BT-110/ZIG-110 4PIN : Connect a 4-pin BT-110, BT-210, ZIG-110, or LN-101. 

This allows to communicate with external peripherals with serial UART 

communications. The LN-101 is more useful than simple firmware download 

from the PC. 
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2.2.4 2mm/2.54 mm prototyping area: located on both sides of the CM-900 board 

with 2.0mm or 2.54mm pitch to facilitate mounting of other devices. 

2.2.5 2 mm GPIO Header :  Allows the CM-900’s STM32F103C8 CPU to freely 

interface with external devices. 

2.2.6 TTL 3 PIN : connect to Dynamixel via 3-pin cable daisy-chain (TTL 

communications). 

2.2.7 RS485 4 PIN : connect to Dynamixel via 4-pin cable daisy-chain (RS-485 

communications). 

2.2.8 Power LED : LED on when board is powered on and LED off when board is 

powered off. 

2.2.9 Status LED : CM-900’s program verification test LED. Send high/low signals 

to pin D16 to turn LED on/off. 

2.2.10 Battery socket : socket to connect battery. 

2.2.11 DC SMPS : jack for 12V SMPS. 

2.2.12 XL-Series 3 PIN : Connect to Dynamixel XL-series via 3-pin TTL 

communications. 

2.2.13 JTAG/SWD 10 PIN: JTAG/SWD terminal for other programming features via 

IAR, Keil. 

 

2.3 Package list 

Component Quan-tity 

Controller CM-900 1 

Download Micro-B-Cable(USB) 1 

Manual User Guide 1 
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2.4 Product characteristics 

 

 

 

  
  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

CM-900 

CPU STM32F103C8 (ARM Cortex-M3) 

Op Voltage 5V~24V( USB 5V, DXL 12V, XL-Series 7.4V) 

I/O GPIO 32 

Timer 8 ( 16bit ) 

Analog In(ADC) 10 ( 12bit ) 

Flash 64 Kbytes 

SRAM 20 Kbytes 

Clock 72Mhz 

USB 1 ( 2.0 FullSpeed ) 

CAN 1 

USART 3 

SPI 2 

I2C(TWI) 2 

Debug JTAG & SWD 

DMA 7ch 

3 Pin TTL 2 

4 Pin RS485 2 

3 Pin XL-Serise 1 

SIZE 60mm X 54 mm X 1.6 mm 
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2.5 Power 

2.5.1 Simply connect via USB and the CM-900 is operational. 

 

 

2.5.2 To drive Dynamixel(s) connect a 12V power supply either via battery or DC 

power. 

 

2.5.3 If 12V SMPS and battery are connected the CM-900 will draw power only 

from the 12V SMPS.  

2.5.4 When SMPS or battery and 5V USB are connected then the CM-900 will halt                   

drawing power from USB. USB connection remains intact. 

 

2.6 Operating 

2.6.1 When the CM-900 is powered by USB or SMPS/Battery it automatically runs 

user code 0x08003000. 

For programming connect the CM-900 to the PC and run its dedicated 

software integrated development environment (IDE) to write code, compile 

and download. 
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<connect the CM-900 to the PC> 

 
<CM-900’s integrated development environment: ROBOTIS CM-9> 
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2.7  Pin layout information 

2.7.1 Power port 

 

 Reverse side also shown 

   

2.7.2 You can see the CM-900’s의 GPIO header pin connections to the  

STM32F103C8 CPU 
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The ‘X’ mark indicates support for future CM-9 series. VDD is 12V. 

Please note Dynamixel-related pins (D6,D7,D19) USB pins (PA11,PA12,PC13)  

are separately connected. 

 

< STM32F103C8(LQFP48 Package) CPU schematic> 
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2.7.3 3-pin TTL 

 
 

Also shown the reverse side silk screen 

 
 

2.7.4  4-pin RS-485 

 
 

  2.7.5  4-pin communications connection 

 
Reverse side 
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2.8  Schematics & PCB Gerber file (Schematic & Gerber Design) 

The CM-900 is an open-source embedded board with open hardware and software. 

The following is a summary of the hardware schematic and PCB Gerber file. 

2.8.1 Schematics : CM-900_REV_1.01_Schematic_20121129.pdf 

2.8.2 PCB Gerber(EAGLE): (TBA) 

 

2.9  Emergency recovery mode 

2.9.1 In case the CM-900’s USB drivers are not detected nor detected by ROBOTIS 

CM connect the 3.3V to D0.  

 
 

2.9.2 Use a conducting pin (i.e. small wire) 
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connect 3.3V pin to D0 

2.9.3 Connect a USB and verify STATUS LED (on). 

 

2.9.4 Go to: File -> examples -> Digital -> Blink then click on the download button.

 

2.9.5 The CM-900 can be programmed via ROBOTIS CM-9. 

 

 

 

 

 



 

 
                                                                      36 

 
    

CCMM--990000   

 

CCMM--990000   

2.10 CM-900 Flash Memory Map 
 
The CM-900 has 64kbytes of memory available where the bootloader takes up 

12kbytes. The remaining is available to the user for programming. The bootloader’s    

binary file begins with 0x08000000. 

2.10.1 Bootloader : 0x08000000 ~ 0x08002FFF 

2.10.2 User Programming Space : 0x08003000 ~ 0x0800FFF0 

 

 
 

  



 

 

 
    

CCMM--990000   

 

37                                                                                       

CCMM--990000   

3 CM-900 IDE software 

3.1 Download ROBOTIS CM-9  

To program the CM-900 you need ROBOTIS CM-9; get it from CM9 Developer’s 

World Circle in BOTSOURCE. 

www.robotsource.org 

 

If you have not yet signed up with ROBOTSOURCE we strongly recommend you do so. 

 

Sign Up is a very simple process. 
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After signing up log in you can proceed to download ROBOTIS CM-9 

 
< simply by signing in with your registered email address> 

Go to CM-9 Developer’s World Circle’s Notice and download ROBOTIS CM-9 SW. 

 

Click on the link according to your computer OS. 
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3.2  ROBOTIS CM-9 structure 

After decompressing the downloaded file the structure will appear as shown below. 

 

3.2.1 Drivers :  contains the Windows .inf USB drivers 
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3.2.2 Examples : Contains the files for examples for ROBOTIS CM-9. 

 

3.2.3 Hardware : contains the CM-9-series C/C++ sources + ARM-based compiler 

 
Robotis folder contains the CM-900’s API core library 

ROBOTIS\hardware\robotis\cores\robotis

 

3.2.4 Java : contains JRE (Java Runtime Environment). 

3.2.5 Lib : ROBOTIS CM-9 resources 

3.2.6 Libraries : sketch libraries 
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3.2.7 Reference : CM-9-series data suite and API documentation 

3.2.8 Tools : ROBOTIS CM-9’s processing-related tools 

3.2.9 ROBOTIS CM-9.exe : ROBOTIS CM-9’s executable 

 

3.3 USB drivers installation 

The CM-900 USB driver installation is an essential requirement. The following 

procedure is Windows-specific. Mac OSX and Linux users do not need the following 

procedure as drivers are already included with the OS.  

When the CM-900 is connected to the PC it will appear as ROBOTIS Virtual COM 

Port in Windows Device Manager. With the right mouse click select update driver 

software.
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Pick “browse my computer for driver software” 

 

 

Click on “browse” and select ‘drivers’ folder (from ROBOTIS\drivers). 
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Click on “install this driver software anyway” 

 

Once install is successful a window will appear as illustrated below 

 

Look for the COM port number under ROBOTIS Virtual COM Port. 
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3.4 Software environment setup 

After USB driver setup double-click on ROBOTIS CM-9.exe. 

 
<ROBOTIS CM-9 window> 

From ROBOTIS CM-9 window you must select a board type and COM number. 

3.4.1 Select a board 

Select the matching version of your CM-900 board. In this case select CM-

900 REV 1.0 (ROBOTIS CM-900 ES is for previous test versions). 
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3.4.2 Select serial port 

Select the COM port number. 

 

Linux users select /dev/ttyACMX. 

 

Mac OS X users select tty.usbmodemX11. 
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3.4.3 Environment setup 

Go to File -> Preferences environment to make changes. 

 

 
Sketchbook location: directory for sketch-based projects including examples. 

Editor language: change font type. 

Console window : view the compilation’s output. Check download to download 

code after compilation. 
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3.5 Download examples 
 
Get ROBOTIS CM-9 example programs from file -> examples. 

 

For example: with Digital I/O open the Blink example, analyze the code then 

download it to the CM-900. This should help make development easier. 

 

In this Blink example shown simply click on the downwards arrow to download the    

code to the CM-900. 
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The following examples are useful for API reference. Please refer to these when 

developing the CM-900. 

 

3.6 Blink example 

 

The CM-900 Blink example is a port of Arduino’s Blink example. 

Go to File -> Examples -> Digital -> Blink 

 

3.6.1 Schematic 

The CM-900’s status LED connects to the CPU via D16(PB2). 
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When D16(PB2) is high the LED is off; when low the LED is on. 

3.6.2 Sketch code 

 

The function pinMode(pin_number, pin_mode) function is used to unitialize.  

Refer to the CM-900 I/O port silk screen; BOARD_LED_PIN is defined for 

pin D16. This is illustrated in the header file CM-900.h. 

ROBOTIS\hardware\robotis\cores\robotis\CM-900.h 
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The Blink example is a simple high/low signal manipulator with OUTPUT 

being the output fuction. 

Once setup() function has been set you can control the LED with 

digitalWrite(pin_number, HIGH/LOW)를 in the loop() via time with 

delay(millisecond). 

3.6.3 Verify data 

Verify the STATUS LED (on or off) 

 

3.7 SerialUSB_HelloWorld example 
 

This is an example to communicate between the CM-900 and external device (i.e. 

PC) via USB. Declare SerialUSB instance to enable USB communications. 

This example show how SerialUSB_HelloWorld communicated with a terminal 

window (PC). 
Go to File -> Examples -> Communication -> SerialUSB_HelloWorld. 
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3.7.1  Connect the CM-900 to the PC 

  

3.7.2  Sketch code 

 

Initialize SerialUSB instance in Setup() with begin() method. The void() type 

returns nothing. Regardless of other serial devices with SerialUSB.begin() 

method setting the baud rate is not necessary. 

In Loop() with SerialUSB.print() or SerialUSB.println() its possible to get output. 

 

3.7.3  Verify data 

      Click on the serial monitor to see output.  This is also possible with RoboPlus 

      Terminal.    
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The serial monitor window can be activated by clicking on the laptop icon 

located on the upper right side. 

 

The same is possible with RoboPlus Terminal (no need to set baud rate). 

 
Other terminal window applications are not yet supported. 



 

 

 
    

CCMM--990000   

 

53                                                                                       

CCMM--990000   

3.8 SerialUSB_Echo example 
 
SerialUSB_HelloWorld example only showed output SerialUSB_Echo example 

allows for both input and output. 

3.8.1  Connect the CM-900 to the PC 

  

3.8.1 Sketch code 

 

Like SerialUSB_HelloWorld there is no need to set baud rate in 

SerialUSB.begin(). 

In Loop() the CPU checks for input repeatedly. In the if clause 

SerialUSB.avaliable() outputs 0 until the condition is met. Once condition is 

met SerialUSB.read() sends 1 byte SerialUSB.print(). 

3.8.2 Verify data 

Use the serial monitor or RoboPlus Termincal to view data. Use the 

keyboard to input data and the CM-900 returns the same input as output, 

therefore is an echo. 
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Any input is returned exactly as output. 

 

3.9  AnalogInSerial example 

The CM-900 has a 12-bit resolution ADC with 10 ports. This makes possible to 

connect multiple devices. The silk screen below shows the available ports. 

 

Pins 14 and 15 are for TIMER, ANALOG IN respectively and are duplicated features; 

with analog input via pinMode() function it is possible to set in analog mode. Input 

pins 0 through 7, 14 and 15 are available for analog input. 

With AnalogInSerial example an analog input received then transmitted via 

SerialUSB. 

This example is accredited to Tom Igoe for Arduino’s board therefore this is an  

Arduino example. 

3.9.1 Schematics 

The CM-900 is connected to a variable resistor (potentiometer). The 

important point is that the maximum allowed input voltage of the CM-900 for 

analog inputs is 3.3V. The schematic below the variable resistor is 

implemented to limit the voltage to 3.3V. 
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3.9.2 Sketch code 

 

This example shows 2 declarations in setup(). In loop() int analogValue 

repeatedly looks for analogRead(pin_number) for analog input. The input 

value is of integer type with 12 bits in range (0-4095). 

SerialUSB.println() outputs value(s) from analogValue. If a hexadecimal 

value output is desired then set SerialUSB.println(analogValue,16), where 16 

denotes hexadecimal; for Binary then 2; octal then 8. The default value is in 

decimal. 
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3.9.3 Verify data 

Open the serial monitor to see output. 

 

 

3.10 Dynamixel Basic example 

The CM-900 includes Dynamixel connectors to facilitate robot development. A pair 

of 3-pin TTL, a pair of 4-pin RS-485, and a XL-series connector are embedded 

onto the board. Also, a DC jack and battery connector are also embedded so 

power can be properly supplied to any connected Dynamixel(s). 

Dynamixel Basic example is analogous to the Blink example as it switches 

Dynamixel between one position to another. 

  

3.10.1  Connecting a Dynamixel 

Connect a 3-pin or 4-pin DYnamixel. Connect the SMPS or battery to the 

CM-900 then run ROBOTIS CM9. 

The default values for Dynamixel are 1 for ID and 1 for baud rate (1Mbps). If 
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not, then set said values with Dynamixel Wizard. 

The CM-900 communicates with Dynamixel serially. 

 

3.10.2 Sketch code 

 
Dynamixel bus must be initialized. From setup() Dxl.begin(baud_rate) is also 

initialized. From here any 3-pin or 4-pin Dynamixel device connected to the 

CM-900 gets initialized. Baud_rate value of 1 means communications speed 

is set to 1Mbps. For further information on Dynamixel API please consult the 

e-manuals. 

From loop() with Dxl.writeWord(ID, Address, Value) function set the value for 

goal position(L) in Address; this corresponds to position portion of Dynamixel, 

and Value being the value of the position. In this example the position 

switches between 100 to 1000 in intervals of 1000ms. 
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Note that the actual position varies with different models of Dynamixel. For 

Dynamixelw with 12-bit resolution (0~4095, 0xFFF) will have a smaller range 

of motion and reach goal position quicker. For more information on goal 

position please consult the e-manuals. 

3.10.3 Verify data 

The only way to verify data is to check motor movement visually. 

 

3.11 Dynamixel ReadWrite example 

This example shows Dynamixel read/write features. This example checks 

Dynamixel movement and change of moving (rotating) direction. Once moving is 

complete position data is then outputted and Dynamixel moves to the next position. 

3.11.1 Connect Dynamixel 

Connect a 3-pin or 4-pin DYnamixel. Connect the SMPS or battery to the 

CM-900 then run ROBOTIS CM9. 

The default values for Dynamixel are 1 for ID and 1 for baud rate (1Mbps). If 

not, then set said values with Dynamixel Wizard. 

The CM-900 communicates with Dynamixel serially. 
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3.11.2 Sketch code 

Some of the parameters from Dynamixel control table have been dfined in 

the preprocessor for simplicity. 

 

 

   

bMoving = Dxl.readByte(id, P_MOVING)  

 

returns a 1 when Dynamixel is moving and 0 when not. If transmission via 

Dxl.getResult() is successful and bMoving = 0 the Goal Position’s index 

changes; Dxl.writeWord(id, P_GOAL_POSITION, GoalPos[INDEX]) 

transmits new data. Value from GoalPos[INDEX] is outputted via USB via the 

following command  

wPresentPos = Dxl.readWord( id, P_PRESENT_POSITION_L ); 

3.11.3 Verify data 

Open up serial monitor to see output from GoalPos[INDEX] and see position 

of Dynamixel visually. 
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3.12 Dynamixel SyncWrite example 

With Dynamixel Broadcast ID its possible to control multiple Dynamixels 

simultaneously. 

This example shows how to control 5 Dynamixels via Syncwrite packet. For 

more information on Syncwrite please consult the e-manuals. 

http://support.robotis.com/ko/e-

manual_kor.htm#product/dynamixel/communication/dxl_instruction.htm 

Go to FIle -> Examples -> Dynamixel -> SyncWrite 
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3.12.1  Connect 5 Dynamixels 

Set ID from 1 to 5 use either 3-pin or 4-pin Dynamixel, or a combination of 

5 using both pin types; connect them in any order. Set baud rate to 1Mbps 

to all 5 Dynamixels. 

 

The CM-900 communicates with the Dynamixels serially. 

3.12.2 Sketch code 

Some of the parameters from Dynamixel control table have been defined in 

the preprocessor. For more information on Dynamixel control table please 

consult the e-manuals. 

Note that 1-byte Word LOW (LSBs) is enough for control. 

 

AmpPos is the initial position of all 5 Dynamixels. 
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Dynamixel bus initialized in setup() with Dxl.begin(1) along with 

SerialUSB.begin(). 

 

In loop() a Syncwrite packet can be divided for Dynamixel communications 

and output. For packet creation instructions please consult the e-manuals. 

 

 

Please note a word (2 bytes) in a Dynamixel packet includes both High 

byte (MSBs) and Low byte word (LSBs). 
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#1: Syncwrite Packet set to Broadcast ID. 

#2: set Instruction Sync Write (0x83) 

#3: Goal Position parameter with value 0. 

#4: assign a word (2 bytes) to Goal Position. 

#5: Assignment for IDs and Parameters 

(data length +1)*(index value i=0,1,2,…) + 2(BROADCAST_ID, INST_SYNC 

_WRITE) 

#6: set word (2 bytes) for Goal Position.  

#7: output goal position via USB 

#8: calculates Packet length (see below) 
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#9: the created Packet is transmitted via Dxl.txrxPacket() method 

Verify data 

Open the serial monitor to see GoalPos[INDEX] of all 5 Dynamixels. 
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4 CM-9 API Reference  
 
This CM-900 API Reference documentation has been created by Martin Mason of 

Mt. San Antonio College of Physics and Engineering. Martin Mason. Thanks to 

Martin Mason for the development and contribution of the CM-9 series. 

4.1 CM-9 code structure 
 

Usually, firmware codes begin with main.c, or main.cpp with void main(). 

 

Default hardware initialization is in board_Init() function and code implemented in 

infinite while or for loops. 

This way code structure of the CM-9 can be divided in hardware and parts. 

Initialize hardware in setup(){}. Place algorithm under loop(){}. 
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Both setup() and loop() reside in main.cpp; the user can create a downloadable 

binary file by implementing these. 

ROBOTIS\hardware\robotis\cores\robotis\main.cpp

 

Open main.cpp… 

 
 

4.2  Dynamixel API 
 

Use Dynamixel class to control Dynamixel(s). To drive Dynamixel(s) Dxl.begin(baur_ 

rate) is required.  Dynamixel class methods are based on Dynamixel SDK. 

For more information on Dynamixel please consult the e-manuals. 

http://support.robotis.com/  

 

Methods: 
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Device Control 

Methods 

void begin(int baud) initialize Dynamixel at set baud rate. 

void end(void) Pause Dynamixel 

 

 

 

High Level 

Communications 

int readByte( int id, int address ) Read 1 byte from Dynamixel 

void writeByte( int id, int address, int 

value ) 
Write 1 byte to Dynamixel 

int readWord( int id, int address ) Read 1 word from Dynamixel 

void writeWord( int id, int address, int 

value ) 
Write 1word to Dynamixel 

void ping(int id) Verify Dynamixel connection status 

void reset(int id) Resets Dynamixel 

int getResult(void) Get response 

void setPosition(int Servoid, int 

Position, int Speed) 

Set position and velocity of 

Dynamixel ID 

 

Packet Methods 

void setTxPacketId( int id ); 

void setTxPacketInstruction( int instruction ) 

void setTxPacketParameter( int index, int value ) 

void setTxPacketLength( int length ) 

int getRxPacketParameter( int index ) 

int getRxPacketLength(void) 

int getRxPacketError( int errbit ) 

Utility methods 
int makeWord( int lowbyte, int highbyte ) 

int getLowByte( int word ) 

int getHighByte( int word ) 

Low Level Communications 
void txPacket(void) 

void rxPacket(void); 

void txrxPacket(void) 

For more information on packet-related methods, utility method, low-level methods 

please consult the e-manuals. 

http://support.robotis.com 
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4.2.1 Getting Started: 
The sketch code shown below sets a Dynamixel baud rate to 1Mbps with 

position switching between value 100 and 1000 with 1000ms pause in 

between.

 

 
 

 

 

4.2.2  Code description 

Every code requires setup() and loop(). 
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Setup:  setup() initializes the CM-900 upon power up or after pressing the 

reset button. Pin mode setup, device initialization also done in this function. 

Dxl.Begin()  Dxl assigned instance with begin() method initializes Dynamixel 

bus. Dxl class instance has more methods other than begin(). 

Loop: loop() runs setup() and repeatedly runs the CM-900 

Dxl.writeword(1,30,100): the first value sets Dynamixel of ID 1. The second 

value setsgoal position (30 of control table). For more information on control 

table please visit support.robotis.com. 

  

  

 

delay (time in milliseconds) : is a set delay time. 

 

4.2.3  Pre-defined constants: 
These predefined constants are convenient and make defining unnecessary. Please 

refer to the predefined constants listed below. 

 

 

 

 

 

 

  

30 (0X1E) Goal Position(L) Lowest byte of Goal Position RW - 

31 (0X1F) Goal Position(H) Highest byte of Goal Position RW - 



 

 

                             70 

 
    

CCMM--990000   

 

CCMM--990000   

Get Result Flags 

Name DEC 

COMM_TXSUCCESS 0 

COMM_RXSUCCESS 1 

COMM_TXFAIL 2 

COMM_RXFAIL 3 

COMM_TXERROR 4 

COMM_RXWAITING 5 

COMM_RXTIMEOUT 6 

COMM_RXCORRUPT 7 

 

 

Instruction Commands 

Name Hex 

INST_PING 0x01 

INST_READ 0x02 

INST_WRITE 0x03 

INST_REG_WRITE 0x04 

INST_ACTION 0x05 

INST_RESET 0x06 

INST_DIGITAL_RESET 0x07 

INST_SYSTEM_READ 0x0C 

INST_SYSTEM_WRITE 0x0D 

INST_SYNC_WRITE 0x83 

INST_SYNC_REG_WRITE 0x84 
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Packet Instructions 

Name DEC 

BROADCAST_ID     254 

DEFAULT_BAUDNUMBER  1 

ID           2 

LENGTH 3 

INSTRUCTION 4 

ERRBIT 4 

PARAMETER 5 

MAXNUM_RXPARAM 60 

MAXNUM_TXPARAM     150 
 

Error Messages 

Name DEC 

ERRBIT_VOLTAGE     1 

ERRBIT_ANGLE     2 

ERRBIT_OVERHEAT        4 

ERRBIT_RANGE     8 

ERRBIT_CHECKSUM     16 

ERRBIT_OVERLOAD     32 

ERRBIT_INSTRUCTION   64 
 

             From the library folder including the header file dynamixel_address_tables.h provides 

an abundance of predefined constants. This also includes peripherals from ROBOTIS 

or third parties, such as HaViMo.  

\ROBOTIS\libraries\dxl\dynamixel_address_tables.h 
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Getting the library…-> select dxl and the #include will be listed (as shown below). 

            

Function Documentation:  refer to ROBOTIS e-Manual v1.11.00 

Dynamixel class is assigned in Dxl instance.  

Implement Dxl in this form: Dxl.instance(1st value, 2nd value,…). 

 

Ex) Dxl.begin(1); // initialize Dynamixel bus to 1Mbps. 

Dxl.writeWord(2,30,512); // sets Dynamixel with ID 2 to goal position of 512. 

 
 
void begin(int baud);  

Initializes Dynamixel bus. 

Parameters 
- int baud 
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Baud is the value that determines communications speed. The relationship between 

baud rate and value is 200000 / (Value + 1). The following table lists the values and 

corresponding baud rates for each value. For example Dxl.begin(34) initializes 

Dynamixel bus with a baud rate of 57600bps. 

Value Actual 

BPS 

Standard 

BPS 

Uncertainty 

0 2000000 2000000 0 

1 1000000 1000000 0% 

3 500000 500000 0% 

4 400000 400000 0% 

7 250000 250000 0% 

9 200000 200000 0% 

16 117647 115200 -2.124% 

34 57142 57600 0.794% 

103 19230 19200 -.16% 

207 9615 9600 -.16% 

 

Default is 1Mbps 

 

Return Values 
- A returned value of 1 means success; 0 for failure. 

 

void end(void);  

            Pauses Dynamixel. 

 

 
 
int readByte( int id, int address );  

Reads 1 byte of address data of Dynamixel. Use from results of communications 

getResult(). 

 

Parameters 
- id 

ID of Dynamized 

- address 
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Address from Dynamixel control table. For more information on Dynamixel control 

table visit support.robotis.com 

Return Values 

- read data values  

 

Example 

data = Dxl.readByte( 2, 36 ); 

if( Dxl.getResult( ) == COMM_RXSUCCESS ) 

{ 

     // using data 

} 

 
void writeByte( int id, int address, int value );  
Writes 1 byte in address of Dynamixel control register. 

 

Parameters 
 - id 

IDof Dynamixel 

   - address 

Address from Dynamixel control table. For more information on Dynamixel control 

table visit support.robotis.com 

- value 

Written data value 

 

  Return Values 
   - none 

 

     Example 

Dxl.writeByte( 2, 19, 1 ); 

if( Dxl.getResult( ) == COMM_RXSUCCESS ) 

{ 

     // Succeed to write 

} 
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int readWord( int id, int address );  

A word is comprised of 2 bytes. A word is the control register address of the 

Dynamixel via its ID. Use this function to get a readout of the control register. For 

example, a read out of goal position (30 in address table) gives a word readout on 

for Goal Position (L) (30 in address table) and Goal Position (H) (31 in address table). 

Use getResult() method where communications is successful. 

Parameters 
- id 

 

ID of Dynamixel  

- address 

 

Address value of Dynamixel from the control table 

Return Values 
- returns a word (2 bytes). 

    Example 

data = Dxl.readWord( 2, 36 ); 

if( Dxl.getResult( ) == COMM_RXSUCCESS ) 

{ 

     // process data here. 

} 

void writeWord( int id, int address, int value );   

A word is comprised of 2 bytes. A word is the control register address of the 

Dynamixel via its ID. Use this function to write the control register. For example, a 

write goal position (30 in address table) then the writeword writes for Goal Position 

(L) (30 in address table) + Goal Position (H) (31 in address table). Use getResult() 

method where communications is successful. 

Parameters 
- id 
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 ID of Dynamixel  

- address 

 Address value of Dynamixel from the control table 

- value 

 Value to be writetn 

 Return Values 

- None 

 

 Example 

Dxl.writeWord( 2, 30, 512 ); 

if( Dxl.getResult( ) == COMM_RXSUCCESS ) 

{ 

     // Write success 

} 

 

 
void ping(int id);  
Verifies Dynamixel bus for connected Dynamixel. Use Dxl.getResult() for verification. 

 

Parameters 
- id 

 

    ID of Dynamixel  

Return Values 
     - None 
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Example 

Dxl.ping( 2 ); 

if( Dxl.getResult( ) == COMM_RXSUCCESS ) 

{ 

      // verification of ID2 successful 

} 

 

void reset(int id);  

Resets Dynamixel. 

  

Parameters 
- id 

 

ID Dynamixel  

Return Values 
- none  

 

Example 

Dxl.reset( 2 ); 

if( Dxl.getResult( ) == COMM_RXSUCCESS ) 

{ 

      // reset ID 2 

} 

 
int getResult(void);  

Checks for packet communications result.  

 

Parameters 

- None 

 

Return Values 
- Returns results. Value types shown below 

Value Meaning 
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COMM_TXSUCCESS Instruction packet transmission successful 

COMM_RXSUCCESS Status packet reception successful 

COMM_TXFAIL Instruction packet transmission failed 

COMM_RXFAIL Status packet reception failed 

COMM_TXERROR Instruction Packet transmission error 

COMM_RXWAITING Status Packet reception error 

COMM_RXTIMEOUT Dynamixel not responding 

COMM_RXCORRUPT Status Packet corrupted 

 
             Example 

result = Dxl.getResult( ); 

if( result == COMM_TXSUCCESS ) 

{ 

} 

else if( result == COMM_RXSUCCESS ) 

{ 

} 

else if( result == COMM_TXFAIL ) 

{ 

} 

else if( result == COMM_RXFAIL) 

{ 

} 

else if( result == COMM_TXERROR ) 

{ 

} 

else if( result == COMM_RXWAITING ) 

{ 

} 

void setPosition(int Servoid, int Position, int Speed);//Created by Martin S. 

Mason(Professor @Mt. San Antonio College) 
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Sets Dynamixel position and velocity. This function sets velocity and position 

registers simultaneously. 

Parameters 
- Servoid   

 

ID of Dynamixel. 

- Position 
 

Goal Position of Dynamixel 

-Speed  

 

Goal velocity of Dynamixel (1-1023 range). 

Return Values 

-none 

 

Example 

result = Dxl.setPosition(3,500,600 ); 

if( Dxl.getResult( ) == COMM_RXSUCCESS ) 

{ 

      // Verify position command has been received 

} 

 

4.3   Zigbee API 

ZigBee is a device allows remote control of the CM900 wirelessly. Simply connect 

to the CM-900’s 4-pin connector and the CM-900. There’s no need to implement 

instances; simply implement the functions listed below. 

[BT-110A] or [BT-110A Set] [BT-210], [ZIG-110A Set] or  [LN-101     
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For detailed information about the 4-pin connector refer to the hardware portion of 

the CM-900 

Device Control 

Methods 

int zgbInitialize( int devIndex ) ZigBee device initialized  

at 57600bps. 

devIndex default value is 0. 

void zgbTerminate(void) Halts the device. 

Data Methods int zgbTxData(int data) Data transmission. 

int zgbRxCheck(void) Vevifies received data 

int zgbRxData(void) Returns value upon successful  

data reception 

 

Example: 

In loop() checks for ZigBee data reception.                 
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4.4 GPIO 

The functions listed below are based on Arduino and Leaflabs. Arduino’s Reference are 

useful because they are relatively easy to understand C/C++ code instead of ARM’s 

codes. Use the links below for more information on Arduino and LeafLabs. 

 

General 

Methods 

pinMode(pin, 

WiringPinMode mode) 
Sets pins for input and output  

Digital 

Methods 

int digitalRead(pin) 
Reads status of a specific High/Low pin 

Said pin must be setup as input 

digitalWrite(pin, value) 
Writes High/Low to a specific pin  

Said pin must be setup as output 

togglePin(pin) 

Set pin to toggle 

i.e. switch from Low to High and from 

High to Low 

Analog 

Methods 

int analogRead(pin) 
Read pin’s analog value 

Said pin must be setup as analog input 

analogWrite(pin, duty 

cycle) 

Writes analog data to pin 

pwmWrite() duty cycle (0~65536 

range) 

Duty cycle can be controlled 

For digital inputs use pins 0-31 of the CM-900. 

Analog IN is engraved in the front portion of the CM-900 PCB. Implement 
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analogWrite(), pwmWrite(), and TIMER on these specified pins. 

Pins 6 through 10, 14,15, 20 through 22 are for TIMER and analogWrite(); pins 0 

through 7, 14, 15 for TIMER and ANALOG IN. Pins 14 and 15 also available for 

analogRead(). 

 

void pinMode(pin, mode) (adopted from Leaf Labs Maple Documentation) 

Changes pin to mode.  

Parameters: 

• pin -  

Pin of the CM-900 

• mode -  

Mode listed below for said pin 

     Values: 

• OUTPUT -  

Basic digital output: when the pin is HIGH, the voltage is held at +3.3v (Vcc) and 

when it is LOW, it is pulled down to ground.  

• OUTPUT_OPEN_DRAIN -  

In open drain mode, the pin indicates “low” by accepting current flow to ground and 

“high” by providing increased impedance.  

An example use would be to connect a pin to a bus line (which is pulled up to a 

positive voltage by a separate supply through a large resistor). When the pin is high, 

not much current flows through to ground and the line stays at positive voltage; when 

the pin is low, the bus “drains” to ground with a small amount of current constantly 

flowing through the large resistor from the external supply. In this mode, no current is 

ever actually sourced from the pin.  
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• INPUT -  

Basic digital input.  

The pin voltage is sampled; when it is closer to 3.3v (Vcc) the pin status is high, and 

when it is closer to 0v (ground) it is low. If no external circuit is pulling the pin voltage 

to high or low, it will tend to randomly oscillate and be very sensitive to noise (e.g., a 

breath of air across the pin might cause the state to flip).  

• INPUT_ANALOG -  

This is a special mode for when the pin will be used for analog (not digital) reads. 

Enables ADC conversion to be performed on the voltage at the pin.  

• INPUT_PULLUP -  

The state of the pin in this mode is reported the same way as with INPUT, but the 

pin voltage is gently “pulled up” towards +3.3v.  

This means the state will be high unless an external device is specifically pulling the 

pin down to ground, in which case the “gentle” pull up will not affect the state of the 

input.  

• INPUT_PULLDOWN -  

The state of the pin in this mode is reported the same way as with INPUT, but the pin 

voltage is gently “pulled down” towards 0v.  

This means the state will be low unless an external device is specifically pulling the 

pin up to 3.3v, in which case the “gentle” pull down will not affect the state of the 

input.  

• INPUT_FLOATING -  

Synonym for INPUT.  

• PWM -  

This is a special mode for when the pin will be used for PWM output (a special case 

of digital output).  

• PWM_OPEN_DRAIN -  

Like PWM, except that instead of alternating cycles of LOW and HIGH, the voltage 

on the pin consists of alternating cycles of LOW and floating (disconnected).  

Discussion 
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pinMode() is a function in  setup() where the pin can be set. The pin must be 

designated for writing. 

Example 

pinMode() sets LED to OUTPUT mode. Use the fuction digitalWrite() to write data 

(high/low). a blinking LED is the result.  

 

uint32  digitalRead  (uint8 pin)  (adopted from Leaf Labs Maple Documentation) 

Reads pin High/Low status.  However, said pin must have INPUT_PULLUP or 

INPUT_PULLDOWN for input. Please refer to pinMode(). 

Parameters: • pin - Declares read pin 

     Return: LOW or HIGH.  

ㆍDiscussion 

If actual pin is not connected HIGH or LOW may be read ramdomly  

ㆍExample 

The following example the LED turns on and off repeatedly with the press of the 
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button 

 

void digitalWrite(uint8 pin, uint8 value) (adopted from Leaf Labs Maple 

Documentation) 

Pins outpurs High/Low 

However, said pin must have OUTPUT_PULLUP or OUTPUT_PULLDOWN for 

output. Please refer to pinMode(). 

Parameters: 

• pin -  

declares write pin 

• value -  

HIGH(1) or LOW (0) 

ㆍDiscussion 

The declared OUTPUT pin outputs 3.3V for HIGH and  0V for LOW. 

ㆍExample 

The following example is an implementation digitalWrite() function from LED Blink 

example. 
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The following allow replacement to toggleLED() inside loop(). This function is for 

the built-in LED. 

 
 

 Or replaced by togglePin().  

 
 

unit16 analogRead(uint8 pin) (adopted from Leaf Labs Maple Documentation) 

Reads pin’s analog value. 
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This  featureis blocked until ADC is converted.  Pin mode must be set to INPUT_ 

ANALOG. 

Parameters: 
• pin -  

Analog pin read 

 

Return: Voltage converted to 12-bit integer (0-4095).  

ㆍ Discussion 

Reads analog value to declared pin. The CM-900 has 16 12-bitchannels. This 

converts input of 0V to 3.3V to 0 to 4095. There are other factors that affect 

accuracy and must be taken into account. 

 To call this fuction  pinMode() function must be implementedand ANALOG_INPUT   

must be set. For more information please check pinMode().. 

ㆍ Parameter Discussion 

The number in this function is the analog pin number. These pin numbers are labeled        

in white on the CM-900’s PCB silk screen along with ANALOG IN. 

ㆍNote 

If a pin is not connected then its readout is not possible. 

        ㆍ Example 
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analogWrite(uint8 pin, uint16 duty_cycle) (adopted from Leaf Labs Maple 

Documentation) 

Given the declared duty cycle of the pin a PWM signal is possible. With CM-900 

PWM signals can be controlled via duty cycle. 

Duty cycle range between 0~65535. 

 

Parameters: 

• pin -  

PWM input pin 

• duty_cycle -  

PWM signal duty cycle (0~65535) 
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Duty cycle can be controlled in the duty cycle input part of the function. 

Values close to 0 the duty cycle is small (small HIGH area). Refer to the diagram 

below larger duty cycles (larger HIGH areas) 

 

  Example 

  The  following is  an example read from the potentiometer to control the brightness of   

  the LED. 

   

void toggleLED() (adopted from Leaf Labs Maple Documentation) 

http://leaflabs.com/docs/lang/api/pwmwrite.html#id2
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Toggles the CM-900 STATUS LED. 

When the LED in on status is called it turns off; when called in off it turns on. 

 

ㆍ Example 

The following is the Blink example for STATUS LED. 

 
 

4.5 Interrupt 

Interrupt is a feature that allows specific actions to be performed based status return. 

An interrupt verification code is separately required because it utilizes hardware 

timer. Despite external devices having its own interrupt, it cannot exceed 16. For 

example pins 0 through 15 each with its own interrupt event there cannot be any 

more interrupts in code.  

The following functions allow control of interrupts 

attachInterrupt(pin,  
voidFuncPtr handler, mode)  

Adds interrupt handler for a specific pin 

detachInterrupt( pin) Removes interrupt handler for a specific pin 

noInterrupts() All interrupts disabled 

Interrupts() All interrupts enabled 

disableDebugPorts() JTAG/SWD disable option 

enableDebugPorts() JTAG/SWD enable option 



 

 

  

CCMM--990000   

 91                                                                       

 

attachInterrupt(uint8 pin, voidFuncPtr handler, ExtIntTriggerMode mode)   

Adapted  from Maple Documentation 

Parameters 

 

• pin – pin # 

• handler – interrupt event pointer 

• mode – interrupt form; falling edge or rising edge 

 

mode 

interrupt event type  

Values: 

 

• RISING -  

Trigger when LOW goes to HIGH 

 

• FALLING -  

Trigger when HIGH goes to LOW 

 

• CHANGE -  

When pins changes HIGH to LOW or LOW to HIGH; 

event trigger regardles 

 

ㆍ Discussion 

The delay() function cannot be used because interrupt 

is processed internally. Also values changed to millis () 

do not increase. Serial data reception process may be 

lost. To prevent data loss Volatile should be declared 

globally. 

 

ㆍ Example 

In this example pin 0 the LED turns on or off when 

there is a signal change. 
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The function blink() is an interrupt handler. When pin 0 inout signal changes blink() 

gets called to high/low. In turn loop() follows the state (value) and sets the LED 

on/off. 

 

4.6  User-created API library 

When executing ROBOTIS CM-9 libraries from the folder \ROBOTIS\library get 

carried. This also includes user’s libraries.  
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4.6.1 CPP-based library creation 

Create file(s) in CPP format;  API’s in core library. 

The following shows user-created example.h header file and example.cpp 

 

In example.h wirish.h has been declared. This makes APIs from digitalWrite() to 

Dynamixel API available from the CM-9 core library. 
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In example.cpp implement setupHelloWorld() and sendHelloWorld().

 

The project can be imported as shown below. 

 
When adding #include <example.h> is automatically included. 
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Now both setupHelloWorld() and sendHelloWorld() can be written. Note that in 

the #include preprocessor the<and>characters refer to ROBOTIS\libraries 

directory. 
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<sketch code> 

Once compiled and downloaded to the CM-900 the results can be seen on 

serial monitor 

 
 

4.6.2 C-based library creation 

Most firmware codes are written in C. C is also available for coding with the CM-

9. The following shows math.c, math.h files under utility folder under example 

library. 

 
Both C-based files under utility directory. 
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 The following show the contents of math.c and math.h files.  

  
 <contents of math.h> 

Let’s look at sum() in ROBOTIS CM-9’s tool chain. Both < > imply looking for a 

directory called include. 

Extern “C” {} required C++-based compilers. 

 
<contents of math.c> 
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The following show modified example.h and example.cpp. 

Declare #include “utility/math.h” 

 

Add sum() function to example.cpp 

 

sendHelloWorld() sketch code outputs sum(1,2) value. 
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4.6.3 Syntax library highlights 

Add keywords.txt file for syntax. 

And place it in the same example directory. 

 

Add the contents of the file as shown below. 

 



 

 

                             100 

 
    

CCMM--990000   

 

CCMM--990000   

In ROBOTIS CM-9 look for a color change when inputting setupHelloWorld() 

and sendHelloWorld(). 

  
<syntax feature> 

4.6.4 Registering a library 

You can register your own library so it can be readily available in the CM-9’s 

menu. 

 
 

Create a directory named “example” then simply place your sketch code inside 

the “example” directory. Restart ROBOTIS CM-9 and your custom-created 

library will shop up in the nemu. 
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The name in the menu will reflect the name of the sketch code file. 
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5 Learning (implementing APIs to CM-900) 

5.1 Digital I/O 

5.1.1 Digital output on pin-16 

Set pinMode(16, OUTPUT) in setup(); this sets pin-16 to OUTPUT  

Declare digitalWrite() to HIGH/LOW. 

 

Pin-16 reads STATUS LED; when HIGH the LED is off; when LOW the LED is 

on. 

 
Blinks in 0.1sec intervals. 

5.1.2 Digital input on pin-1 

Set pinMode(1, INPUT) in setup(); this sets pin-1 to INPUT. 

If external pull-up needed set pinMode(1, INPUT_PULLUP); for pull-down set 

pinMode(1, INPUT_PULLDOWN). 

digitalRead() gets HIGH/LOW value. If pin is not connected then value could 

be random. 
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verify the code. 

 

5.1.3 Toggle pin-1 

Switch pin-1 from high-to-low then low-to-high.
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5.2 Analog I/O 

 

Analog input pins are labeled ANALOG IN on the CM-900’s silk screen. Pins 0 through 

7,14, and 15 are input pins. 

 

Analog output requires PWM, which is used by TIMER, for analog output.  

5.2.1 Analog input on pin-0 

Set pinMode(0, INPUT_ANALOG) in setup(); this sets pin-0 to INPUT_ANALOG. 

 

// pin-0gets analog input, value assigned. 

The assigned value gets converted in a 12-bit ADC value (0~ 4095).

 

5.2.2 Analog output (PWM) on pin-6 

Set pin-6 to pinMode(6, OUTPUT) or pinMode(6, PWM). 
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Analog output as PWM. PWM’s duty cycle is set on the second value (10000). 

Range is 0~ 65535. 

 

In analogWrite() the second value is PWM’s implementation as duty cycle.

 
 

5.3 Serial comm 

The  CM-900  has a total of 3 serial devices. These are USART serial1, serial 2, 

and serial3. Serial1 is assigned to Dynamixel comm port. Serial2 for 4-pin BT-210, 

BT-110 devices. To see the serial pins see reverse side of CM-900. Serial1 has 

TX1 and RX1. Serial2 has TX2 and RX2. Serial3 has TX3 and RX3. 
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<Serial2> 

Serial USB device download is USB communications. 

Serial USB devices are controlled via SerialUSB method. 

5.3.1 Transmit data via serial device 

Initialize device in and run in loop(). 

 

Data transmission can be outputted with print() and println(). print() has no 

line brakes while printIn() does. 

 

 “Hello World” is outputted via Serial2(TX2, RX2) device. 
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println() outputs in a new line.

 

 
Outputs 12 in decimal (default) 

 
Outputs abc as 128 

 
Outputs abc in hexadecimal (0x80) 

 
Outputs abc in binary 

 
Outputs a double data type and ends line; outputs 2 significant places 

Can output declared double variables. 
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Input analog values to pin-0, pin-1, pin-2; in turn output via Serial2.

 

sensorValue2 outputs all 3 pins one line at a time with println().

 

5.3.2 Receive data from serial device 

Echo feature can be implemented with serial devices. 

Assign temp as char type and save data from Serial2 with read(); use print() to 

output data for echo purposes. 
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Interrupt implementation 

Interrupts from serial devices do not return values. Incoming data can be 

echoed with print(). This can be implemented without declaring separate 

prototypes. 
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serialInterrupt() can be implemented as a pointer in setup() 

 
Let’s see code with serial2 device. 

 

5.3.3 Output data with serial USB device 

initialize SerialUSB device in setup(); run code in loop(). There is no need to 

declare baud rate value. 
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Use print() and println() for control. 

 

Output 12 in decimal (default). 

 

Output declared int type 

 

Output abc in hexadecimal 

 

abc’s 128 is outputted to hexadecimal (0x80) 
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abc outputted in binary 

 
Output of double type; output is 3.14 

Declared double type 

 
Outputs var as is (with 3 significant figures) 

5.3.4 Receive data with serial USB device 

Implement echo to serial USB device  

Assign temp as char type and save data from serial USB device with read(); 

use print() to output data for echo purposes. 
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Interrupt implementation 

Interrupts from serial USB do not return values byte and *byte types are 

implemented. Incoming data can be echoed with print(). When data is written 

to the USB COM port is done 1byte chunks (nCount). Only index 0 of 

transmitted byte is necessary for echoing. 

 

Implement usbInterrupt()pointer on setup() through attachInterrupt(). 

 

Its ok to keep loop() empty. 
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Let’s have a look at SerialUSB device’s interrupt code.

 

 

5.4 Math functions 

Trigonometric functions can be implemented to ROBOTIS CM-9 without any 

additional header files. 

5.4.1 Basic math functions 

Get analog input and receive a value less than 100.
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min(a,b) only returns values lower than 100. Anything greater than 100 

sensorValue does not get assigned. 

Oppositely the following return values greater than 0.

 

max(a,b) only returns values greater than 0. Anything lesser than 0 there is no 

return. 

Receive an analog input and get values only between 0 to 100. 

constrain(x,a,b) returns x (if x is between and and b).

 

When receiving converter analog values (0~4096) these are mapped 1:1. This 

is due to PWM having outputs (0~65535). 

This can be done with map() function

 

Calculate 93 (nine cube). 

                  Simply implement pow(double x, double y) function 

                  

for squares there’s a macro sq(a). 

with 32 
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calc returns 9. 

Square roots √   

Simply implement sqrt(double x) function. 

 
Calc returns 2. 

 

5.4.2 Output Sin, Cos, Tan 

Implement the following functions to obtain sin, cos, and tan. 

 
where x is in radians. 

 

Set a radian value of 3.14  

 

 

5.5 Time functions 

Time unit is in milliseconds 

 

The time variable returns millisecond values. Time increases until overflow. 

Please refer to the millis() function type. 
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The following has time unit in microseconds. 

 

time returns microsecond values. Value increases until overflow (about the 70 

min mark) then it resets to 0. 

Time variable outputted by SerialUSB device.

 

Adding delay() to a blinking LED. 

The CPU does nothing (remains in standby) for 1 second. 

With void delay(unsigned long ms) set a value of 1000 for a delay of 1 second.

 

for reference 1 sec = 1,000 millisecond ,1 millisecond = 1,000microsecond 
a short 500us delay. 
To implement microsecond delays to the CPU implement 
void delayMicroseconds(unsigned int us) function. 

 

However, accuracy of the CM-900’s CPU(STM32) is not guaranteed with 

regards to microsecond-type precisions 
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5.6 Random numbers 

Let’s have 0~10 randomly. 

long random(long max) or long random(long min, long max)

 

there is no need to declared a minimum value; only maximum.

 
 

5.7 External interrupt 

Have the LED turn on/off when pin-0 gets input signals. 

Declare global variables and toggle flags in interrupt routines. 

Attach interrupts with attachInterrupt(). 

 

Implement exInterrupt() as void exInterrupt(void) type. 
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In loop() STATUS LED turns on/off based on state 

 

5.8 Dynamixel 

The following example is for ID=1 and baud rate set at 1Mbps [Dxl.begin(1) = 1M bps]. 

5.8.1 Read the AX-12Afirmware version 

The following shows the e-manual’s AX-12A control table model number and 

firmware addresses. 

 

Read ID1’s model number (address 0, LSBs portion) and firmware version 

(address 2). 
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the following lines are for output. 

 

 
<output> 

5.8.2 Read ID1 current temperature 

The following shows the temperature address in the control table. 

 
Use readByte() to get data. 

 

5.8.3 Set the AX-12 to ID2. 

Use readWrite() to set address 3. 
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Set ID change in setup(). Always check for communications success.ID 1 is 

now ID 2. 

5.8.4 Change baud rate to 57600 bps 

To change ID change address 4 (baud rate) via readWrite(). 

Refer to the index listing the baud rates; 57600 bps has a value of 34. 
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Once baud rate is changed initialize Dynamixel with Dxl.begin(34). 

 

5.8.5 Move (rotate) ID 1 

Address 46 (0x2E) of the control table deals with moving aspect.  

 

 

When ID1 moves bMoving returns 1; when not 0. 
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5.8.6 Move the AX-12A to the 150-degree position 

For a goal position of 150 its respective address value must be called (Goal 

Position L/H). 

Goal position is expressed as a word (2 bytes). The table below shows both 

addresses needed to comprise the Goal Position word. Goal Position (L) 

(address 30). Use writeWord() to issue position command. 

 

Please refer to the diagram below (also found in the e-manuals) with the 

position with respect to angles. 

 
Use Dxl.getResult() to verify communications. 

5.8.7 Set different speeds with several RX-64s 
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To have several Dynamixels move simultaneously issue the command 

syncWrite. syncWrite creates a packet then transmits it. Set the packet with 

setTxPacketXXXX(). 

 

 

 
Set Goal Position and Moving Speed. Dxl.getLowByte() and Dxl.getHighByte() 

is explicit to high byte (MSBs). 

 

Declare position and velocity values. 
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5.8.8 Limit action between 0~150 degrees 

Use CCW Angle Limit 0x3FF to set limit from 300 degrees to 150 degrees. 

Use writeByte() to send command. 

 

 
 

5.8.9 Set input voltage between 10V ~ 17V 

10V value is 100(0x64) and 17V is 170(0xAA). Use writeByte() to set 

commandThe address value from the control table is 12(0x0C) LSBs and 

13(0x0D) MSBs. 

 

 
 

5.8.10  Set torque to 50% of max 

 Set a max Torque (0x3FF) to 50% (0x1FF). Max Torque’s LSBs address is    

14(0x0E). Use writeByte() to send command. 
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Turn power off then turn it back on to have new torque take place. 

5.8.11 Set position of 180 degrees at 57RPM 

Declare: 

  

 

5.8.12 Set ID 0 position of 0 and ID 1 of 300 (both must operate simultaneously) 

Use  Syncwrite and setTxPacketXXX () to create a packet with  INST_REG_ 

WRITE and INST_ACTION. For reference 0 degrees is 0 (0x000) and 300 

degrees is 1023 (0x3FF). 
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Second Dynamixel packet transmission 
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While ID0 and ID1 are pending INST_ACTION packet is transmitted to run 

instructions  

 

Check for communications success every time a packet is sent. 
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6  Appendix 1: Download the bootloader with the ST-LINK 

6.1  Download the bootloader with the ST-LINK 

6.1.1  The CM-900 has a 10-pin JTAG header. Connect a ST-LINK to download a 

newbootloader. 

 
<ST-LINK/V2> 

 
< 20 PIN to 10 PIN Converter > 

However, the ST-LINK/V2 needs a 20PIN to 10 PIN JTAG Converter to 
properly connect to the CM-900.  

Connect the converter’s 20-pin end to the ST-LINK/V2 and the 10-pin and to 

the CM-900. 
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6.2  When connecting the ST-LINK the CM-900 must have power supplied separately by 

either USB or SMPS/Battery. 

 
<USB-based power> 

 
<SMPS-based power> 
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6.3 Download the ST-LINK Utility (drivers included). 

http://www.st.com/web/en/catalog/tools/PF258168 

Decompress the file and double-click on STM32 ST-LINK Utility_v2.x.x.exe and install 

everything, including ST-LINK’s driver. 

 

From Windows Device Manager the STLink dongle will show up as STMicroelectronics 

STLink dongle. 

 

Run STM32 ST-LINK Utility. 

 

From Target -> Settings choose SWD(Serial-Wire Debug). 
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6.4 Download the CM-900’s bootloader. 

http://www.robotsource.org/xe/Circle_CM9_Developer_World 

 

For bootloader updates check www.robotsource.org periodically. 

Like all CM-900 software the bootloader can also be modified and built. For more 

information refer to Appedix 2. 

6.5 From File -> Open file select CM900_FullBinary_20XXXXXX.bin (see icon shown 

below). 
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When the window pops up choose the binary file. 

 
 

6.6  Go to Target -> Program or Program & Verify . Leave Start address as is (0x08000000). 

 

 

After integrity check is complete (Verification) you get a verification notification.

 

Download is now complete. Press the reset button of the CM-900. 
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6.7 Advanced users can use development environment tools like IAR E/W, Keil uVision, 

etc; and use the CM-900’s JTAG port to edit, doenload, step-by-step debugging, and 

create custom firmware. However, to use ROBOTIS CM-9 software then the 

bootloader must be downloaded again.. 

 
<IAR Embedded Workbench> 

 
<Keil uVision> 
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7 Appendix 2 utilizing the source 

The CM-900’s hardware and software are open-source. You can access the source via 

Github. You can use the source to develop your own robot development environment and 

share your code with everybody.  

The descriptions below are based on Windows OS but Linux and Mac OSX is also 

possible with Eclipse. 

7.1  ROBOTIS CM9 source location 

https://github.com/robotis-pandora/ROBOTIS_CM9_Series.git

 

7.1.1 Firmware: contains the components for the bootloader. The ROBOTIS CM9’s 

Wiring APIs, compiler and firmware also located in core library. The CM-9’s 

compiler and downloadable firmware located in core-library_0x08003000 directory.  

The bootloader starts at the flash memory’s 0x08000000 location the 

downloadable firmware starts at 0x08003000. 
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7.1.2 CM-9_ide: The ROBOTIS CM9 is based on Arduino 1.0.1, where Arduino is based 

on Processing, hence the reference to Processing-core project. In ROBOTIS 

CM9’s  IDE is implemented as Processing-head.  Therefore,  to develop the IDE  

modify  processing-head 

 

7.2 To run Eclipse download and install Java Development kit. 

http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-

1880260.html

 

Click on Accept then download and install the appropriate version for your OS. 

TO verify proper installation of JDK enter the command as shown below. 
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7.3 Importing your project in Eclipse 

Use Eclipse’s git plug-in for easy acquisition of sources from GitHub. Get C/C++ 

language type for firmware and Java for IDE. Get the most recent version. 

Eclipse download : http://www.eclipse.org/ 

Get the C/C++ package. 

 

In your PC download either 32-bit or 64-bit version. To check Java version enter the 

command java –version. If the environment version is 32-bit but you got the 64-bit 

then it won’t run and viceversa. 

7.3.1 Run the git plug-in from Eclipse. 

 

Go to Window -> Show View -> Other… 
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Select Git Repositories and the git plug-in will appear in a view window. 

 
Click on Clone a Git repository 
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Copy the link https://github.com/robotis-pandora/ROBOTIS_CM9_Series.git. 

The other parts should autofill. Alternately, from the ROBOTIS_CM-

9_Series’s Github site click on the copy to clipboard icon. 
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Click on next 
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Click on next 

 

In Destination select the repository directory. 
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Click on Finish to finish obtaining the source. 

 

Once cloning is complete a Master branch appears. Expand the node until you 

see ROBOTIS CM9. 

 

You can develop firmware with Eclipse C/C++ package (firmware folder only). 

For ROBOTIS CM-9 IDE use Eclipse Java package. 

7.3.2 Importing the bootloader project 

The CM-900 bootloader resides in the CPU’s (STM32F103C8) internal flash 

memory from 0x08000000 and up to 12-kbytes in size. 12 kbytes should not 

be exceeded otherwise it would take up space from core-library, from 

0x08003000, therefore firmware cannot be executed. 
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In the repository’s Working Directory go to Firmware -> bootloader_0x08000000; 

with the right mouse click select Import Projects… 

 

From Wizard for project import select Import existing projects and click on 

Next. 
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Click on Finish to include the project with Eclipse. 
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Project Explorer import complete. 

 

Expand the node and you will see the C files for the bootloader. 

 
The contents of main.c shown below. 
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7.3.3 Importing core-library project 

The core-library project for the bootloader is on Wiring’s variant of C++. Import 

the core-library project. 

From Eclipse’s Git Repository select core-library_0x08003000 and from the 

pop-up menu select  Import Projects… 

 

From Select a wizard… click on next. 
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From Import Projects make sure you see cm9-core-library then click on finish 

to finish importing. 
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Both bootoader and cm9-core-library projects will appear. 

 

From the cm9-core-library project open template.cpp and you should notice 

this is the same from ROBOTIS CM-9’s sketch code. 

 

From template.cpp fill out setup() and loop() functions. This way you can edit 

robot development environment with Eclipse. 

 

7.4 Register Code Sourcery G++ Lite environment variables 

You can build the CM-900’s bootloader and firmware with Code Sourcery G++ Lite 

tool chain. There is no need to download Code Sourcery G++ Lite separately. From 

the ROBOTIS CM9 folder follow the path below. 
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   Go to ROBOTIS\hardware\tools\arm\bin directory look for arm-none-eabi-XXX. 

 

 

Register this path with Windows environment variables. Once registered do not 

delete this directory otherwise Eclipse will not be able to build. 
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Go to Control Panel -> System -> Advanced -> Environment variables. 

 

Enter the path for tool chain. 

 

rom command prompt enter arm-none-eabi-gcc and you should see a response as 

shown below. 
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7.5  Bootloader build and download 

By now you should know how to get ROBOTIS CM-9 Series source via GitHub and 

register Code Sourcery G++ Lite tool chain environment variables.  

Use the ST-LINK to download the build. 

You may use OpenOCD, IAR, or Keil to download. However, the next section is 

dedicated for ST-LINK utility 

From Apendix 1 bootloader download you are required to have the 20-pin to 10-pin 

converter. 

The ST-LINK dongle and the converter cable are not included with the CM-900 
and must be purchased separately. 
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7.5.1 Connect the ST-LINK to the CM-900. 

 
<ST-LINK/V2> 

 
< 20 PIN to 10 PIN Converter > 

Connect the 20-pin end to the ST-LINK/V2 and 10-pin end to the CM-900. 
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7.5.2 Supply power to the CM-900 separately. 

 
<Power input via USB> 

 
<Power input via SMPS> 

7.5.3 Download the ST-LINK Utility (device drivers included). 

http://www.st.com/web/en/catalog/tools/PF258168 

Decompress the file and run STM32 ST-LINK Utility_v2.x.x.exe; the ST-LINK 

driver is also automatically installed. 

 

Connect the ST-LINK to the PC via USB.. 
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To verify proper installation from Windows Device Manager go to the Universal 

Serial Bus controllers -> STMicroelectronics STLink dongle. 

7.5.4   Verify ST-LINK_CLI.exe location. 

C:\Program Files (x86)\STMicroelectronics\STM32 ST-LINK Utility\ST-LINK 

Utility 

 
Register this path with Eclipse. 

7.5.4 Building the bootloader. 

Open any C file from STM32F103C8_bootloader project (say main.c). Proceed 

to build project. 
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Go to Project -> Build Project to begin build. Upon successful build you should 

see a message fro m the console as shown below. 

 

From the active project explorer (tree nodes) press the F5 key to refresh and 

STM32F103C8_bootloader.bin will appear. 
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binary build complete 

The following is about Eclipse shortcuts for easier usage. 
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Go to Window -> Preferences for general preferences. 

 
Go to Preferences -> General -> Key.  

Enter build project on the search line and the command for build project 

appears. Click on Binding and press F7 to designate the items. Go to Conflicts 

to verify of any possible conflicts if none click on Apply. 

 

Likewise by entering Clean Build Clean items will pop up; press the F6 key for 

the binding shortcut. 
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Afterwards register shortcuts for external tools. 

Enter External on search and Run Last Launched External Tool pops up; press 

Ctrl+F5 for shortcut. 
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7.5.5 er External Tools with ST-LINK_CLI.exe and download. 

Go to Run -> External Tools -> External Tools Configurations… 

 

You will get a window as shown below. 

 

Click on New launch configuration icon 
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Name : Program with ST-LINK V2. 

 

From the Main tab: click on Browse File System select the path for ST-

LINK_CLI.exe. 

C:\Program Files (x86)\STMicroelectronics\STM32 ST-LINK Utility\ST-LINK 

Utility\ 

 

Select ST-LINK_CLI.exe. 
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Assign a working directory. Use Eclipse’s common environment variables. 

Click on Variables… 

 

On the current project select ${project_loc}. 

 

 
 



 

 

  

CCMM--990000   

 163                                                                       

Click on Apply then click on Run to download. 

 

The console should output a message as shown below for successful downloa. 

 

Run ST-LINK_CLI.exe from the registered External Tool. 
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Or press Ctrl + F5. 

 

 

7.6 core-library project build and download 

7.6.1 Build the cm9-core-library project  

Open template.cpp. Or any other file from the cm9-core-library. 

 

Press F7 for the shortcut or go to Project -> Project Build. 
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7.6.2 External Tool Configuration for cm9-core-library 

Configure external tools before downloading cm9-core-library.bin. this is due 

to the different addresses for bootloader and user-created firmware. The CM-

900’s cm9-core-library begins at the flash memory’s 0x08003000 address. 

 

Create new external tools (as shown below). 
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Upon successful download the MCU resets. 

 

In Template.cpp press Ctrl+F5 for shortcut and the CM-900’s의 Status LED 

blinks.
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7.7 cm-9_ide source build 

7.7.1 Download Eclipse’s Java package. 

http://www.eclipse.org/downloads/ 

 

download either 32-bit or 64-bit version according to the version of your 

computer. 

7.7.2 from the workspace import cm-9_ide directory. 

 

The path, for example,  C:\Users\Chase\git\ROBOTIS_CM9_Series\ is the 

starting point. However, importing cm-9_ide folder from another path is OK. 

Copy cm-9_ide folder from your git repository to the Java (Eclipse) 

workspace
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Go to File -> Import. 

 
 

GO to General -> Existing Projects into Workspace; then click on Next 
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Browse… click on browser and look for the copied folder in the Java 

workspace.

 

The copied cm-9_ide folder is assigned. 
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Click on OK and you should see 2 projects 

 

Click on Finish to register both projects. 
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7.7.3 from Ant tools in runtime options register tools.jar 

 

From Preferences -> Ant -> Runtime items click on Classpath tab 
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From Ant Home Entries(Default) add the path to tools.jar by clicking on Add 

External JARs… 
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7.7.4 from Project Explorer add build.xml 
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7.7.5 Right click on the file and go to Run As -> 2 Ant Build… 

 

7.7.6 Select all parts 

 

7.7.7 Control the build sequence as shown below 
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In the pop-up window use the Up/Down to set order. 

 
Click on OK after setting order 

 
    Click on Run to begin build 
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In Ant Input Request pop-up window enter v0.9.9 (that’s the version of your 

generated IDE). 

 

Click on Ok. Build time depends on the computing power of the computer. 

The approximate build time is about can be from 90 second to as long as 5 

minutes. 

 

7.7.8 ROBOTIS CM9 launches 
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7.7.9 The zip is stored in the set path built on the implemented Java version. For 

example, ROBOTIS-v0.9.9-windows.zip contains java v0.9.9. 

 

The executable is located inside work folder. 
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